PART II: Up and Running with openNAS

I have a 320 gig Maxtor ATA with 16 meg cache installed. The output of hdparm:

~ # hdparm /dev/hda

/dev/hda:
 multcount      =  0 (off)
 IO_support     =  0 (default 16-bit)
 unmaskirq      =  0 (off)
 using_dma      =  1 (on)
 keepsettings   =  0 (off)
 readonly       =  0 (off)
 readahead      =  8 (on)
 geometry       = 38913/255/63, sectors = 625142448, start = 0
~ # hdparm -Tt /dev/hda

/dev/hda:
 Timing cached reads:   148 MB in  2.02 seconds = 73.27 MB/sec
 Timing buffered disk reads:  36 MB in  3.05 seconds = 11.80 MB/sec

 Timing cached reads:   152 MB in  2.01 seconds = 75.62 MB/sec
 Timing buffered disk reads:  36 MB in  3.04 seconds = 11.84 MB/sec

http://all6250.blogspot.com/ 
http://openwrt.org/
http://tobe.mine.nu/
http://www.uclinux.org/
http://forum.opennas.info/
http://wiki.opennas.info

ntx_libra.tgz

 

J1: Power pack
J2: Current supply of the non removable disk
J3: Current supply of the exhaust
J4: COM1
J5: Net socket
J6: COM2 (?)
JP1: JTAG (?)
JP2: IDE interface
SW1: In/circuit breaker
SW2: RESET tracer
LD1: Power LED
LD2: HDD-LED
LD3: Net traffic LED

In the Netronix NH-220 NAS devices the BRECIS MSP2006 MIPS32 4Km processor is blocked. Here it concerns one on 170Mhz clocked MIPS CCU. As is the case for others embedded/NAS here a MMU is missing to systems to the store management.
The CCU is accessible over a JTAG interface.
http://wiki.openwrt.org/OpenWrtDocs/Customizing/Hardware/JTAG_Cable
http://forum.opennas.info/viewtopic.php?t=188&highlight=ads
http://all6250.blogspot.com/

Load Firmware extensions
To enable the Unicode and UPNP function for the device, you have to install the "ntx_libra.tgz" file to the device before any configuration.

To install the file,
1. Insert the included CD and click the "Browse" button.
Note: The Install Menu may auto run. Click "EXIT" to close it.
2. Select your CD-Rom drive. Select Firmware Extensions Gigabit SATA NAS with USB folder. Select the "ntx_libra.tgz" file and click "Open" to browse the file.
3. Click "Apply" to perform installation.
4. It takes a few seconds to perform installing, please wait upon installation.

http://translate.google.com/translate?u=http%3A%2F%2Fforum.opennas.info%2Fviewtopic.php%3Ft%3D61%26highlight%3Dads&langpair=de%7Cen&hl=en&safe=off&ie=UTF-8&oe=UTF-8&prev=%2Flanguage_tools1